-
Case Nelson authored
* Script to copy athena jdbc jar to our maven repo Since amazon is still not putting their athena jdbc on to maven, the easiest thing for us to do is setup a maven-y s3 repo and copy their jar into it. This script allows you to run: `./bin/athena.bb <version> [--deploy]` For example: `./bin/athena.bb 2.0.35 --deploy` Will download the 2.0.35 jar from amazon's release bucket, create and update the necessary maven repo files, then upload all those files to our maven repo. It uses the jar build WITHOUT the AWS SDK. You must have `bb` (babashka), `aws` (awscli), and `shasum` commands available. You must have aws credentials available, e.g. through `aws configure` * Add comment explaining script to script * Use iterate instead of loop for find-pred Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com> * Update bin/athena.bb Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com> * Update bin/athena.bb Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com> --------- Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com>
Case Nelson authored* Script to copy athena jdbc jar to our maven repo Since amazon is still not putting their athena jdbc on to maven, the easiest thing for us to do is setup a maven-y s3 repo and copy their jar into it. This script allows you to run: `./bin/athena.bb <version> [--deploy]` For example: `./bin/athena.bb 2.0.35 --deploy` Will download the 2.0.35 jar from amazon's release bucket, create and update the necessary maven repo files, then upload all those files to our maven repo. It uses the jar build WITHOUT the AWS SDK. You must have `bb` (babashka), `aws` (awscli), and `shasum` commands available. You must have aws credentials available, e.g. through `aws configure` * Add comment explaining script to script * Use iterate instead of loop for find-pred Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com> * Update bin/athena.bb Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com> * Update bin/athena.bb Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com> --------- Co-authored-by:
metamben <103100869+metamben@users.noreply.github.com>
Code owners
Assign users and groups as approvers for specific file changes. Learn more.